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GeoMx DSP Introduction

GeoMx® Digital Spatial Profiler (DSP) is a new technology 

platform which enables spatial analysis of RNA and protein 

in tissue specimens on slides. Samples are stained with large 

panels of pre-mixed biological probes (each which incorporate 

a unique, UV-cleavable DNA barcode) and fluorescently-labeled 

morphology markers (used to visually or computationally 

elucidate the morphology of the tissue). Using the fluorescent 

morphology markers for guidance, defined regions of interest 

(ROIs) are illuminated with UV light and the cleaved barcodes 

from these ROIs are then counted on an nCounter platform. This 

allows for high-plex RNA or protein quantitation from spatially-

resolved regions within the tissue. The resulting counts constitute 

an expression or protein profile of key targets across that ROI and 

elucidate the biology specific to that region.

GeoMx DSP In a Service Environment

In FIGURE 1 the GeoMx DSP Practical workflow is summarized 

(more details in the GeoMx DSP Instrument User Manual). When 

running GeoMx DSP experiments in a service environment client 

input is recommended and may sometimes even be required at 

some points in this workflow. Because of the way the GeoMx DSP 

instrument and workflow is setup, this interaction does not need to 

be physically on-site, but can be done remotely. Points of remote 

interaction are illustrated in FIGURE 2 indicating the practical 

workflow. Potential points of customer/client input can be at the 

stage of ROI selection and segmentation and at the stage of data 

analysis and interpretation (steps 3, 6, and 7 in FIGURE 2). In the 

subsequent sections, some suggestions are made, and guidelines 

are given in order to have a streamlined workflow with an optimal 

customer or client interaction where needed.

FIGURE 1: GeoMx DSP Overall Workflow
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FIGURE 2: GeoMx DSP Practical Workflow
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External Access to the GeoMx DSP Software

There are a number of ways in which remote access to the  

GeoMx DSP software can be organized (summary in TABLE 1). 

This access can be setup to be: 1. visual access only, where the 

second party (i.e. the customer or client) can only view the GeoMx 

DSP software environment but the software control is driven from 

the host-side (i.e. CRO or Core/Service Facility), or 2. the second 

party also gets control over the DSP software (either full control, 

or limited control, depending on the way it is setup).

The easiest way to set this up is via online-meeting platforms ( i.e. 

Zoom or Cisco WebEx). These platforms allow both “view only” 

modes (desktop sharing), but also have the capability of handing 

over desktop control. For example, the service provider could setup 

an online meeting with a client to discuss/review the ROI selection 

strategy. If desired, during this meeting the service provider could 

give the client desktop-control access to control the DSP instrument 

(from the service provider’s desktop environment while connected 

to the GeoMx DSP software through the Google Chrome-based web 

app, via the service provider’s internal network).

Alternatively, the service provider can setup a Virtual Private 

Network (VPN) connection for their client. This will allow the 

client to remotely connect to the internal network of the service 

provider, allowing for a direct internal network connection to the 

GeoMx DSP software. User, group, and folder access permission 

can be put in place to ensure a secure environment for each client 

to ensure data protection and exclusivity. Via this VPN connection, 

access to the GeoMx DSP software is enabled and the client 

can do their own ROI selection and, ultimately, data analysis. 

Important to know is that such data connection would be similar 

to remote connection to the GeoMx DSP instrument from the 

physical internal network of the service provider, with the same 

capabilities and restrictions. One of these restrictions is that such 

a connection will not allow for the operation of the GeoMx DSP 

instrument itself; there will only be access to the Data Analysis 

Suite, but not to the Instrument Control Center.

Online Meeting Environment VPN

Simultaneous Logons 1 Multiple

ROI selection and segmentation Yes, driven by service provider and guided by client Yes, driven by client

Data Analysis Yes, driven by service provider and guided by client Yes, driven by client

Folder visibility/access permission No, controlled by service provider during online session Yes, User-Group-Folder access control

Simultaneous instrument operation Yes Yes

Number of clients simultaneously 
connected

>1 Note: too many simultaneous connections may 
impact instrument performance in terms of slide 
processing time. It is recommended to schedule and 
keep track of logons in a calendar.

>1 Note: too many simultaneous connections may 
impact instrument performance in terms of slide 
processing time. It is recommended to schedule and 
keep track of logons in a calendar.

TABLE 1: overview of remote access options

Setup online-meeting environment

For setting up online-meetings using for example Cisco WebEx, 

Zoom, or Microsoft Skype (or alternative solutions) please consult 

the applicable provider’s support and guidance documentation.

Setup VPN access environment

For on-demand access to the GeoMx DSP software remotely, it 

is recommended to require a VPN connection from clients with 

limited access to the web service on the instrument. An SSL 

VPN solution such as Pulse Connect Secure or Cisco SSL VPN 

will allow clients to securely connect to the instrument’s web 

interface to perform ROI selection and data analysis. The VPN 

can log all incoming connections to provide an audit trail. In this 

environment, VPN access does need to be managed separately 

from the on-instrument access control. The service provider 

should work closely with its IT and Network Administration teams 

to design a secure solution.
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User-Group-Folder Access

Generating users, groups, and folders with the right permissions 

will help protect client data from being visible and accessible 

by other clients when for example logged on to the instrument 

through a VPN connection and logged on to the GeoMx DSP Data 

Analysis Suite. See the GeoMx DSP Instrument User Manual for 

detailed guidelines. In summary, Folders can hold slide records, 

scan cards, and data analyses. The access model is based around 

groups, where folder access is given to one or more groups. There 

are two permission levels (i.e. roles) with respect to users: admin 

or regular user. Admin users have access to everything and can 

also create new users and groups. A regular user only has access 

to folders that the group/groups to which they belong.

A proposed way of working is to:

1. Create one folder for each client, naming using whatever 

convention is appropriate for the service environment, i.e. 

client name or anonymous identifier

1. With the client folder, create sub-folders representing 

different projects

1. Set group access permissions to these folders (main client 

folder or sub-folders)

1. Create users and assign each user to groups linked only to 

folders to which they need access

To illustrate the above, in Figure 3 an example of a folder structure 

and their group assignments is displayed. A user in the Ph1-G 

group would see and be able to access everything in folders 

“Pharma 1”, “P1-ProjectA”, and “P1-projectB”, but would not 

see and not have access to the “BioTech 1” folder and its sub-

folders. A user in the BT1-G-Main group would see and be able 

to access everything in folder “BioTech 1”, “BT-1-Project A”, and 

“BT1-ProjectB”. A user in the BT1-G-Main group would also see 

the “Pharma 1” folder but would not be able to see the contents 

or access anything in that folder. A user in the BT1-G-Main group 

would see and be able to access all content in the “P1-ProjectB folder.

Creating Slide Records

Slide records can be created during the DSP run workflow. To 

ensure a faster workflow, new slide-records can already be set 

as a pre-work step by the service provider’s technician or project 

manager. For more details, see the “Creating Slide Records” 

section of the GeoMx DSP Instrument Manual.

Pharma 1

P1-ProjectB

Ph1 G

Ph1 G

Ph1 G
BT1-G-Main

BioTech 1

BT1-ProjectB

BT1-G-Main

BT1-G-Main

BT1-G-Main

Group AssignmentsFolder Structure

P1-ProjectA

BT1-ProjectA

FIGURE 3: example of folder structure and group assignments – 

folder names are user-chosen and can be de-identified to protect 

customer identity if necessary

Study Design and ROI Selection in a Service Environment

Completing a study for a client in a service environment can be 

streamlined by making sure the experimental aims of the study 

are discussed and documented (see DSP Project Workplan 

document) well in advance with all parties involved in the project. 

Tightly connected with the experimental aims are ROI selection 

and segmentation strategy, which in turn guides appropriate 

morphology markers needed. Please refer to MAN-10108 “GeoMx 

DSP Experimental Design Guideline” for basic best practices 

around experimental setup. In addition, we have found the 

following practices to be useful as a service provider through the 

Nanostring Technology Access Program. 

Discuss Morphology Markers and ROI Selection  

Strategy in Advance

Morphology markers, in the context of GeoMx DSP, are any 

fluorescently-conjugated reagents used to visualize the 

tissue. While Nanostring has several pre-kitted morphology 

markers for solid tumor/tumor microenvironment visualization, 

Alzheimer’s disease, and Parkinson’s disease, the customer is 

free to use whatever antibodies they wish provided they are 

directly conjugated to an appropriate fluorophore. Wavelength 

specifications for the filters available on the instrument can be 

found in MAN-10088 GeoMx DSP Instrument Manual, but in  

general terms they are FITC, Cy3, Texas Red, and Cy5.  
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Many companies provide antibodies directly conjugated to these 

fluorophores, or there are commercial kits available for conjugating 

antibodies yourself. Please note, we recommend use of Syto 13 or 

Syto 83 as a nuclei marker, which occupy the FITC or Cy3 channel, 

respectively. Nuclei staining is the most straightforward target for 

autofocus on the instrument and is strongly recommended for all 

experiments. Use of DAPI or other UV-excitable nuclear markers 

is not compatible with the GeoMx DSP. Outside of our pre-kitted 

morphology reagents, antibody titration may be required to ensure 

sufficient staining for visualization, however the concentrations and 

exposure times listed in the manuals for our off the shelf reagents 

are good starting places.

Use of RNAscope reagents, or fluorescently-conjugated in situ 

hybridization probes, is compatible with the GeoMx DSP RNA 

assays. Refer to MAN-10087 Slide Preparation for a protocol. 

This can be additionally beneficial with targets that do not have 

viable antibodies generated to detect them, or for identifying cells 

that have active transcription (i.e. using RNA scope to identify 

transgene producing T-cells in the context of immunotherapy, 

or virally infected cells). Please note, at the moment, RNAscope 

signal cannot always be used for ROI segmentation due to the 

punctate, intracellular nature of the staining pattern, but can help 

with guiding the placement of the ROIs on the tissue.

Unless the tissues of interest have been extensively characterized 

by Immuno-Fluorescence (IF) in the past, we strongly recommend 

performing a fluorescent morphology marker only stain of the tissue 

as a pilot experiment. This will allow the validation of morphology 

marker(s) performance and enable the parties involved in ROI 

selection (i.e. client, GeoMx technician, Pathologist, etc.) to discuss 

the results and refine their experimental approach. This will 1) 

ensure that the ROI selection strategy proposed by the client is 

feasible in the tissues they intend to have analyzed, and 2) allow for 

a detailed scope of work and ROI selection criteria to be generated, 

which will streamline the process for the larger experiment. 

Once the slides are on the instrument, they must remain on the 

instrument through collection, within 6 hours. Having a robust, 

predefined ROI selection strategy minimizes the time required for 

those approving the ROIs to be available and either in front of the 

instrument or remotely engaging with it. These meetings can be 

arranged via teleconference environment or VPN access to allow 

the client to interact with the software directly (see TABLE 1). This 

initial fluorescent marker evaluation will be especially important 

in the context of GeoMx RNA applications; not all antibodies will 

perform ideally under the antigen retrieval conditions of the RNA 

assay, and some optimization may be required. 

Addressing and Validating Custom Oligo-tagged  

Profiling Content 

If a customer is interested in custom oligo labelling of antibodies 

or ISH probes, reach out to GeoMXsupport@nanostring.com or to 

your Nanostring sales representative. Depending on the service 

environment (i.e. a Contract Research Organization), the customer 

may contract directly with the service provider for these services 

and list this service as a pass-through cost. For custom RNA 

reagents, probes can be designed with very similar algorithms to 

the ones that are utilized for NanoString’s nCounter® bulk gene 

expression assays tiling across a target transcript. NanoString 

does not do any target testing for custom probe validation, 

but the end user is free to (and should) validate them with 

experimental positive and negative control samples. 

For antibody labelling, our partnership with AbCam allows 

customers access to the AbCam library of antibodies validated for 

use in IHC. AbCam can label up to 5 antibodies for inclusion with 

any Nanostring protein core assay (i.e. the Immune Cell Profiling 

core or Neural Cell profiling core). The labelling service through 

AbCam will include target testing pre- and post-oligo conjugation. 

If the customer is interested in an antibody not available through 

AbCam, or an antibody they generated themselves, antibodies can 

be conjugated through the Nanostring Protein Barcoding Service 

(PBS), up to 10 antibodies total. Contact your NanoString sales 

representative for more information. Validation by NanoString of 

PBS custom conjugated antibodies is not possible because of limited 

availabilities of different tissue types. NanoString recommends the 

end user to validate pre and post conjugated antibodies on positive 

and negative tissues, or discuss the possibility with NanoString’s 

PBS to perform some validation if positive and negative tissue 

samples can be provided by the end-user. As a guide, please refer to 

Merritt et al., Multiplex digital spatial profiling of proteins and RNA 

in fixed tissue, Nature Biotechnology, 38, pages 586-599 (2020), 

and our white paper “Multi-step Antibody Validation for the GeoMx 

Digital Spatial Profiler.”

Batching Slides to Minimize Variability

Slides that were prepared for the protein assays are stable, when 

mounted in Fluoromount G, at 4°C in the dark for up to 4 weeks. 

In a service environment, this allows for flexibility in batching work 

according to the demands of the project queue and staffing, as 

well as minimizing any potential variability due to different days/

times/technicians involved with slide preparation. For the RNA 

assay, once labelled, slides may be stored in 2X SSC for up to 48 

hours at 4°C in the dark before they must be processed through 

the GeoMx DSP instrument to avoid loss of signal.

mailto:GeoMXsupport%40nanostring.com?subject=GeoMx%20Support
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Data Transfer Guidelines

At this moment, the GeoMx DSP software does not have an 

import/export functionality allowing to export full studies and 

import them in another instance of the GeoMX DSP software.

The following data types may be exported and transferred to 

the service provider’s client, with or without an accompanying 

descriptive report.

Datasets

Datasets may be exported in .xlsx format by opening or creating a 

data analysis study, going to the Datasets Panel, and hovering over 

a dataset name followed by clicking the export icon. More details 

can be found in MAN-10090 GeoMx DSP Data Analysis manual.

As a minimum it is recommended to provide the Initial Data 

and the QC Data (representing the raw data) to the client, as 

from here all subsequent data processing and analysis steps can 

be done manually outside of the DSP software. Please contact 

GeoMXsupport@nanostring.com for sample data sets if needed.

Images

Slide scan images may be exported from the Scan Workspace 

environment in the Export menu. Rendered Scan Images can be 

exported as a full-color publication quality image. Images will 

be exported in PNG format and one can choose to export the 

scan only, the scan + segments, the scan label + segments, or 

everything. Alternatively, RAW Channel Images can be exported 

in case single-channel high-resolution images are required. 

Depending on the chosen image export type, images can be 

exported as .jpeg, .png, or .tiff. A more detailed description 

and more information can be found in MAN-10088GeoMx DSP 

Instrument Manual.

ROI images

From the ROI menu in the Scan Workspace, for each ROI 

individually the Export Image icon can be clicked in order to 

export a 16-bit multi-channel tiff image. Alternatively, there is also 

an option to export all ROI images at once.

These exported images can be used in an external program (such 

as ImageJ) to create segments within an ROI outside of the GeoMx 

DSP software. Subsequently, the generated masks can be imported 

back into the GeoMx DSP software to apply the masks on the ROIs.

In order to generate a color RGB image from an exported ROI 

image, a program like ImageJ (https://imagej.nih.gov/ij/) or 

alternative can be used. RGB images can be more easily used 

for reporting purposes (e.g. in a PowerPoint presentation or in a 

written project report). In ImageJ, the steps to take are:

• Open multi-channel tiff in ImageJ

• You will now have an image that consists of multiple channels

• To switch the view between the channels, scroll to the desired 

channel image with the horizontal scroll bar (or use the ">" and 

"<" keys)

• In the menu go to Image > Color > Make Composite

• Click OK to confirm

• Optional: in order to change the color of each channel:

 - Scroll to the desired channel image with the horizontal scroll 

bar (or use the ">" and "<" keys)

 - In the menu go to Image > Lookup Tables > pick the desired 

color for the selected channel image

 - Repeat for the other channel images

• In the menu go to Image > Type > RGB Color

• In the menu go to File > Save As > save the image in the 

desired file format

Visualizations

Visualizations from datasets may be exported using the exports 

functionality in the visualizations pane. Click the Export (.xlsx) 

icon in order to export the data on which the visualization at hand 

is based on. Click the Export(.svg) icon in order to export the 

visualization image to an .svg image file. More details on Saving 

& Exporting of data and images can be found in the GeoMx DSP 

Data Analysis manual.
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